package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)T40[0-9][0-9][.][a-zA-Z]+`)
var str = `T4018.test.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}