#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Content-ID:\h+<c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>\R\s*((?:(?!--uuid).*\R)*)--uuid"
Local $sString = "HTTP/1.1 200 OK" & @CRLF & _
"Date: ..." & @CRLF & _
"Server: ....." & @CRLF & _
"Set-Cookie: ....; Path=/; HttpOnly" & @CRLF & _
"Set-Cookie: ...; Path=/; HttpOnly" & @CRLF & _
"Content-Type: multipart/related; type="application/xop+xml"; boundary="uuid:0f7fa750-c317-4039-897a-a90685b00d29"; start="<...>"; start-info="text/xml"" & @CRLF & _
"Keep-Alive: timeout=5, max=99" & @CRLF & _
"Connection: Keep-Alive" & @CRLF & _
"Transfer-Encoding: chunked" & @CRLF & _
"" & @CRLF & _
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29" & @CRLF & _
"Content-Type: application/xop+xml; charset=UTF-8; type="text/xml";" & @CRLF & _
"Content-Transfer-Encoding: binary" & @CRLF & _
"Content-ID: <root.message@cxf.apache.org>" & @CRLF & _
"" & @CRLF & _
"<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><ns2:downloadAttachResponse xmlns:ns2="http://..../"><return><errStr></errStr><result>0</result><contentFile><xop:Include xmlns:xop="http://www.w3.org/2004/08/xop/include" href="cid:c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org"/></contentFile></return></ns2:downloadAttachResponse></soap:Body></soap:Envelope>" & @CRLF & _
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29" & @CRLF & _
"Content-Type: application/octet-stream" & @CRLF & _
"Content-Transfer-Encoding: binary" & @CRLF & _
"Content-ID: <c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>" & @CRLF & _
"" & @CRLF & _
"%PDF-1.4" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
" LOTS OF BINARY CODE HERE FOR THE PDF" & @CRLF & _
"" & @CRLF & _
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29--"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")