import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Content-ID:\\h+<c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>\\R\\s*((?:(?!--uuid).*\\R)*)--uuid";
final String string = "HTTP/1.1 200 OK\n"
+ "Date: ...\n"
+ "Server: .....\n"
+ "Set-Cookie: ....; Path=/; HttpOnly\n"
+ "Set-Cookie: ...; Path=/; HttpOnly\n"
+ "Content-Type: multipart/related; type=\"application/xop+xml\"; boundary=\"uuid:0f7fa750-c317-4039-897a-a90685b00d29\"; start=\"<...>\"; start-info=\"text/xml\"\n"
+ "Keep-Alive: timeout=5, max=99\n"
+ "Connection: Keep-Alive\n"
+ "Transfer-Encoding: chunked\n\n"
+ "--uuid:0f7fa750-c317-4039-897a-a90685b00d29\n"
+ "Content-Type: application/xop+xml; charset=UTF-8; type=\"text/xml\";\n"
+ "Content-Transfer-Encoding: binary\n"
+ "Content-ID: <root.message@cxf.apache.org>\n\n"
+ "<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\"><soap:Body><ns2:downloadAttachResponse xmlns:ns2=\"http://..../\"><return><errStr></errStr><result>0</result><contentFile><xop:Include xmlns:xop=\"http://www.w3.org/2004/08/xop/include\" href=\"cid:c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org\"/></contentFile></return></ns2:downloadAttachResponse></soap:Body></soap:Envelope>\n"
+ "--uuid:0f7fa750-c317-4039-897a-a90685b00d29\n"
+ "Content-Type: application/octet-stream\n"
+ "Content-Transfer-Encoding: binary\n"
+ "Content-ID: <c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>\n\n"
+ "%PDF-1.4\n"
+ "...\n\n"
+ " LOTS OF BINARY CODE HERE FOR THE PDF\n\n"
+ "--uuid:0f7fa750-c317-4039-897a-a90685b00d29--\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}