re = /Content-ID:\h+<c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>\R\s*((?:(?!--uuid).*\R)*)--uuid/m
str = 'HTTP/1.1 200 OK
Date: ...
Server: .....
Set-Cookie: ....; Path=/; HttpOnly
Set-Cookie: ...; Path=/; HttpOnly
Content-Type: multipart/related; type="application/xop+xml"; boundary="uuid:0f7fa750-c317-4039-897a-a90685b00d29"; start="<...>"; start-info="text/xml"
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Transfer-Encoding: chunked
--uuid:0f7fa750-c317-4039-897a-a90685b00d29
Content-Type: application/xop+xml; charset=UTF-8; type="text/xml";
Content-Transfer-Encoding: binary
Content-ID: <root.message@cxf.apache.org>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><ns2:downloadAttachResponse xmlns:ns2="http://..../"><return><errStr></errStr><result>0</result><contentFile><xop:Include xmlns:xop="http://www.w3.org/2004/08/xop/include" href="cid:c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org"/></contentFile></return></ns2:downloadAttachResponse></soap:Body></soap:Envelope>
--uuid:0f7fa750-c317-4039-897a-a90685b00d29
Content-Type: application/octet-stream
Content-Transfer-Encoding: binary
Content-ID: <c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>
%PDF-1.4
...
LOTS OF BINARY CODE HERE FOR THE PDF
--uuid:0f7fa750-c317-4039-897a-a90685b00d29--"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end