#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d+.\d+.\d+ \d+:\d+[\r\n]+)(?!.*[\r\n](\d+)?-(\d+)?)([ a-zA-ZäöüÄÖÜßé0-9'-]{3,})+"
Local $sString = "28.01.2023 11:00" & @CRLF & _
"GERMANY" & @CRLF & _
"OWVA2" & @CRLF & _
"07.01.2023 06:00" & @CRLF & _
"JAPAN" & @CRLF & _
"940-750" & @CRLF & _
"Laden" & @CRLF & _
"28.01.2023 12:00" & @CRLF & _
"FRANCE" & @CRLF & _
"ANDY" & @CRLF & _
"-" & @CRLF & _
"07.01.2023 09:30" & @CRLF & _
"NORWAY and SWEDEN" & @CRLF & _
"-" & @CRLF & _
"07.01.2023 09:30" & @CRLF & _
"SPAIN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")