import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d+.\\d+.\\d+ \\d+:\\d+[\\r\\n]+)(?!.*[\\r\\n](\\d+)?-(\\d+)?)([ a-zA-ZäöüÄÖÜßé0-9'-]{3,})+";
final String string = "28.01.2023 11:00\n"
+ "GERMANY\n"
+ "OWVA2\n"
+ "07.01.2023 06:00\n"
+ "JAPAN\n"
+ "940-750\n"
+ "Laden\n"
+ "28.01.2023 12:00\n"
+ "FRANCE\n"
+ "ANDY\n"
+ "-\n"
+ "07.01.2023 09:30\n"
+ "NORWAY and SWEDEN\n"
+ "-\n"
+ "07.01.2023 09:30\n"
+ "SPAIN";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}