import re
regex = re.compile(r"(?<=\d+.\d+.\d+ \d+:\d+[\r\n]+)(?!.*[\r\n](\d+)?-(\d+)?)([ a-zA-ZäöüÄÖÜßé0-9'-]{3,})+", flags=re.MULTILINE)
test_str = ("28.01.2023 11:00\n"
"GERMANY\n"
"OWVA2\n"
"07.01.2023 06:00\n"
"JAPAN\n"
"940-750\n"
"Laden\n"
"28.01.2023 12:00\n"
"FRANCE\n"
"ANDY\n"
"-\n"
"07.01.2023 09:30\n"
"NORWAY and SWEDEN\n"
"-\n"
"07.01.2023 09:30\n"
"SPAIN")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")