import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]?)([+-]?[0-9][0-9]*(\\.[0-9]*)?)";
final String string = "twentyseven27 (if you get something in first group, invalid)\n"
+ "27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)\n"
+ "e37, e+25.42, (in this case it should not be valid as it is stuck to a letter)\n"
+ "e25.42 (now there's a string in the first group)\n";
final String subst = "<$1, $2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}