// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z]?)([+-]?[0-9][0-9]*(\.[0-9]*)?)").unwrap();
let string = "twentyseven27 (if you get something in first group, invalid)
27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)
e37, e+25.42, (in this case it should not be valid as it is stuck to a letter)
e25.42 (now there's a string in the first group)
";
let substitution = "<$1, $2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}