use strict;
my $str = 'twentyseven27 (if you get something in first group, invalid)
27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)
e37, e+25.42, (in this case it should not be valid as it is stuck to a letter)
e25.42 (now there\'s a string in the first group)
';
my $regex = qr/([a-zA-Z]?)([+-]?[0-9][0-9]*(\.[0-9]*)?)/mp;
my $subst = '<$1, $2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";