using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(.+?)-(\w+)$";
string input = @"Example A:
Input:
something-E123
Example B:
Input:
some-text-EABC
Example C:
Input:
something-something-moretext-EA1A
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}