const regex = /(?m)^(.+?)-(\w+)$/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(.+?)-(\\w+)$', 'gu')
const str = `Example A:
Input:
something-E123
Example B:
Input:
some-text-EABC
Example C:
Input:
something-something-moretext-EA1A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}