using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Action\s*\d*\s*:[\s]*(.*?)[\s]*Action\s*\d*\s*Input\s*\d*\s*:[\s]*(.*)";
string input = @"I can use the `ls` command to list the contents of the directory and `grep` to search for the specific file.
Action:
Terminal
Action Input:
ls -l ~/.bashrc.d/
Action\s*\d*\s*:[\s]*(.*?)\nAction\s*\d*\s*Input\s*\d*\s*:[\s]*(.*)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}