import re
regex = re.compile(r"Action\s*\d*\s*:[\s]*(.*?)[\s]*Action\s*\d*\s*Input\s*\d*\s*:[\s]*(.*)", flags=re.MULTILINE)
test_str = ("I can use the `ls` command to list the contents of the directory and `grep` to search for the specific file.\n\n"
"Action:\n"
"Terminal\n\n"
"Action Input:\n"
"ls -l ~/.bashrc.d/\n\n"
"Action\\s*\\d*\\s*:[\\s]*(.*?)\\nAction\\s*\\d*\\s*Input\\s*\\d*\\s*:[\\s]*(.*)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")