import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<.+?>";
final String string = "<!-- wp:paragraph {\"style\":{\"color\":{\"text\":\"#ffffff\",\"background\":\"#709372\"}}} -->\n"
+ "<p class=\"has-text-color has-background\" style=\"background-color:#709372;color:#ffffff\">This is a paragraph block with a <strong>background</strong>. Professionally productize highly efficient results with world-class core competencies. 5 < 1 Objectively matrix leveraged architectures vis-a-vis error-free applications. Completely maximize customized portals via fully <researched metrics. Enthusiastically generate premier action items through web-enabled e-markets. Efficiently parallel task holistic intellectual capital and client-centric markets.<br></p>\n"
+ "<!-- /wp:paragraph -->\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}