const regex = /<.+?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<.+?>', 'g')
const str = `<!-- wp:paragraph {"style":{"color":{"text":"#ffffff","background":"#709372"}}} -->
<p class="has-text-color has-background" style="background-color:#709372;color:#ffffff">This is a paragraph block with a <strong>background</strong>. Professionally productize highly efficient results with world-class core competencies. 5 < 1 Objectively matrix leveraged architectures vis-a-vis error-free applications. Completely maximize customized portals via fully <researched metrics. Enthusiastically generate premier action items through web-enabled e-markets. Efficiently parallel task holistic intellectual capital and client-centric markets.<br></p>
<!-- /wp:paragraph -->
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}