re = /<.+?>/
str = '<!-- wp:paragraph {"style":{"color":{"text":"#ffffff","background":"#709372"}}} -->
<p class="has-text-color has-background" style="background-color:#709372;color:#ffffff">This is a paragraph block with a <strong>background</strong>. Professionally productize highly efficient results with world-class core competencies. 5 < 1 Objectively matrix leveraged architectures vis-a-vis error-free applications. Completely maximize customized portals via fully <researched metrics. Enthusiastically generate premier action items through web-enabled e-markets. Efficiently parallel task holistic intellectual capital and client-centric markets.<br></p>
<!-- /wp:paragraph -->
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end