using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\p{Lu}[^,]++(?=, \d|$)";
string input = @"Senator, 1.4balbal
rule 46.1, declares
Town, 24
A Town with a Long Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}