$re = '/\b\p{Lu}[^,]++(?=, \d|$)/m';
$str = 'Senator, 1.4balbal
rule 46.1, declares
Town, 24
A Town with a Long Name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);