const regex = /\b\p{Lu}[^,]++(?=, \d|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\p{Lu}[^,]++(?=, \\d|$)', 'gm')
const str = `Senator, 1.4balbal
rule 46.1, declares
Town, 24
A Town with a Long Name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}