package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I have created .* number <b>REQUK[0-9]{9,11}</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?`)
var str = `I have created a incident with your request. This is your incident number <b>REQUK0005652859</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}