use strict;
my $str = 'I have created a incident with your request. This is your incident number <b>REQUK0005652859</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?';
my $regex = qr`I have created .* number <b>REQUK[0-9]{9,11}</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}