package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)started(.*?(?:stored\s+(\d+)\s+)?)finished`)
var str = `started xx xxxxxxx xxxxx xxxxxx xx xxxxxxxxx xxxxxxx xxxx xx
xx xxx xxxxx xxxx xxxxxxxx xxxx xxxxxx found 9999 xxxxx xxxxx
xxx xx xxxx xxxx xxxxxxxxxxx xxxxxxx xxx stored 9999 finished`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}