re = /started(.*?(?:stored\s+(\d+)\s+)?)finished/
str = 'started xx xxxxxxx xxxxx xxxxxx xx xxxxxxxxx xxxxxxx xxxx xx
xx xxx xxxxx xxxx xxxxxxxx xxxx xxxxxx found 9999 xxxxx xxxxx
xxx xx xxxx xxxx xxxxxxxxxxx xxxxxxx xxx stored 9999 finished'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end