import re
regex = re.compile(r"started(.*?(?:stored\s+(\d+)\s+)?)finished", flags=re.DOTALL)
test_str = ("started xx xxxxxxx xxxxx xxxxxx xx xxxxxxxxx xxxxxxx xxxx xx\n"
"xx xxx xxxxx xxxx xxxxxxxx xxxx xxxxxx found 9999 xxxxx xxxxx\n"
"xxx xx xxxx xxxx xxxxxxxxxxx xxxxxxx xxx stored 9999 finished")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")