package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\+\d{1})?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s-.]?\d{4}`)
var str = `Match on a phone number in ANY standard phone number format.
PHONE: 210 210-2100 123123a1
+1(210)-210.2100-KYLEV
210 210-2100
+1(210)-210.2100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}