import re
regex = re.compile(r"(\+\d{1})?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s-.]?\d{4}")
test_str = ("Match on a phone number in ANY standard phone number format.\n"
"PHONE: 210 210-2100 123123a1\n"
"+1(210)-210.2100-KYLEV\n"
"210 210-2100\n"
"+1(210)-210.2100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")