re = /(\+\d{1})?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s-.]?\d{4}/
str = 'Match on a phone number in ANY standard phone number format.
PHONE: 210 210-2100 123123a1
+1(210)-210.2100-KYLEV
210 210-2100
+1(210)-210.2100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end