#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<item>[\s\S]*?<sub>(.*?)<\/sub>((?!<sub>)[\s\S])*<\/item>"
Local $sString = "<item> fffffffffffff" & @CRLF & _
"<sub>aaaa</sub>" & @CRLF & _
"<value>111</value>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<sub>eeee</sub> arg34ddddddddddddddd" & @CRLF & _
"<atag>ddd</atag>" & @CRLF & _
"<sub>aaaa</sub>" & @CRLF & _
"<value>222</value>" & @CRLF & _
"</item>" & @CRLF & _
"" & @CRLF & _
"<item>" & @CRLF & _
"<sub>eeee</sub> arg34ddddddddddddddd" & @CRLF & _
"<atag>ddd</atag>" & @CRLF & _
"<sub>aaaa</sub>" & @CRLF & _
"</item>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")