import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<item>[\\s\\S]*?<sub>(.*?)<\\/sub>((?!<sub>)[\\s\\S])*<\\/item>";
final String string = "<item> fffffffffffff\n"
+ "<sub>aaaa</sub>\n"
+ "<value>111</value>\n"
+ "</item>\n\n"
+ "<item>\n"
+ "<sub>eeee</sub> arg34ddddddddddddddd\n"
+ "<atag>ddd</atag>\n"
+ "<sub>aaaa</sub>\n"
+ "<value>222</value>\n"
+ "</item>\n\n"
+ "<item>\n"
+ "<sub>eeee</sub> arg34ddddddddddddddd\n"
+ "<atag>ddd</atag>\n"
+ "<sub>aaaa</sub>\n"
+ "</item>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}