#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.((?<!\.spec\.)ts|(?<!\.t\.)sol|go|js|mod|sum)$"
Local $sString = "# Should match" & @CRLF & _
"h.ts" & @CRLF & _
"h.sol" & @CRLF & _
"" & @CRLF & _
"# Should not match" & @CRLF & _
"h.spec.ts" & @CRLF & _
"h.t.sol" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")