re = /\.((?<!\.spec\.)ts|(?<!\.t\.)sol|go|js|mod|sum)$/m
str = '# Should match
h.ts
h.sol
# Should not match
h.spec.ts
h.t.sol
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end