$re = '/\.((?<!\.spec\.)ts|(?<!\.t\.)sol|go|js|mod|sum)$/m';
$str = '# Should match
h.ts
h.sol
# Should not match
h.spec.ts
h.t.sol
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);