using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdub(s|bed|bing)?\b";
string input = @"Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Dubbing PL]-GROUP.mkv
Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Eng, Rus, PL Dubs]-GROUP.mkv";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}