const regex = /\bdub(s|bed|bing)?\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdub(s|bed|bing)?\\b', 'gmi')
const str = `Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Dubbing PL]-GROUP.mkv
Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Eng, Rus, PL Dubs]-GROUP.mkv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}