using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[\[)(?<search>.*?)(?!.\]\])(?=\]\])";
string input = @"[[item.property1]] [[item.property2]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[[1][0]]]] [[item.property[1]]]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}