re = /(?<=\[\[)(?<search>.*?)(?!.\]\])(?=\]\])/
str = '[[item.property1]] [[item.property2]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[[1][0]]]] [[item.property[1]]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end