$re = '/(?<=\[\[)(?<search>.*?)(?!.\]\])(?=\]\])/';
$str = '[[item.property1]] [[item.property2]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[0]]] [[item.property[1]]]
[[item.property[[1][0]]]] [[item.property[1]]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);