import re
regex = re.compile(r"\baddresses: \[\d\.\d\.\d\.\d(?:,\d\.\d\.\d\.\d)*]", flags=re.MULTILINE)
test_str = ("version: 2\n"
" renderer: networkd\n"
" ethernets:\n"
" enp0s3:\n"
" dhcp4: no\n"
" addresses: [192.168.1.222/24]\n"
" gateway4: 192.168.1.1\n"
" nameservers:\n"
" addresses: [8.8.8.8,8.8.4.4]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")