re = /\baddresses: \[\d\.\d\.\d\.\d(?:,\d\.\d\.\d\.\d)*]/m
str = 'version: 2
renderer: networkd
ethernets:
enp0s3:
dhcp4: no
addresses: [192.168.1.222/24]
gateway4: 192.168.1.1
nameservers:
addresses: [8.8.8.8,8.8.4.4]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end