#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:^Description: (?P<description>(?:(?!^Notes: ).)+))(?:^Notes: (?P<note>.+))?"
Local $sString = "Title: Blue truck" & @CRLF & _
"Date: 2021-02-11" & @CRLF & _
" " & @CRLF & _
"Description: The truck is blue." & @CRLF & _
"It carries a lot of stuff. " & @CRLF & _
"" & @CRLF & _
"Notes: This one looks damaged."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")