$re = '/(?:^Description: (?P<description>(?:(?!^Notes: ).)+))(?:^Notes: (?P<note>.+))?/ms';
$str = 'Title: Blue truck
Date: 2021-02-11
Description: The truck is blue.
It carries a lot of stuff.
Notes: This one looks damaged.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);