import re
regex = re.compile(r"(?:^Description: (?P<description>(?:(?!^Notes: ).)+))(?:^Notes: (?P<note>.+))?", flags=re.MULTILINE | re.DOTALL)
test_str = ("Title: Blue truck\n"
"Date: 2021-02-11\n"
" \n"
"Description: The truck is blue.\n"
"It carries a lot of stuff. \n\n"
"Notes: This one looks damaged.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")