use strict;
my $str = 'abcd1234567
1234567
123-4567
02221234567
0222-1234567
+862221234567
+86-222-123-4567
+86(222)1234567
86-222-1234567
r 1234567 er
e 123-4567 e
ewq 02221234567 qw
2312 0222-1234567 232
we +862221234567 23
231 +86-222-123-4567 ewe
,,,, +86(222)1234567 sss
ff 86-222-1234567 dd
Some string here with no phone number
a number with 7 and more digits is input
and it starts with 0 or + symbols
and could contain optional symbols "-", "(" and ")"
also enforce whitespace boundaries';
my $regex = qr/^(?!.*(?: |^)(?:\+\d|0)(?:[()-]*\d){6,}(?!\S)).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}