import Foundation
let pattern = #"^(?!.*(?: |^)(?:\+\d|0)(?:[()-]*\d){6,}(?!\S)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd1234567
1234567
123-4567
02221234567
0222-1234567
+862221234567
+86-222-123-4567
+86(222)1234567
86-222-1234567
r 1234567 er
e 123-4567 e
ewq 02221234567 qw
2312 0222-1234567 232
we +862221234567 23
231 +86-222-123-4567 ewe
,,,, +86(222)1234567 sss
ff 86-222-1234567 dd
Some string here with no phone number
a number with 7 and more digits is input
and it starts with 0 or + symbols
and could contain optional symbols "-", "(" and ")"
also enforce whitespace boundaries
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)