const regex = / +?on.*?/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' +?on.*?', 'm')
const str = `Posted by ondrej on 29 Feb 2020`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);