$re = '/ +?on.*?/m';
$str = 'Posted by ondrej on 29 Feb 2020';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;