import re
regex = re.compile(r" +?on.*?", flags=re.MULTILINE)
test_str = "Posted by ondrej on 29 Feb 2020"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)