package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z0-9](-?[a-z0-9])*$`)
var str = `login
lo-gin
Log23gin
log2-3gin
L--login
L--lo--gin
L---login
---login
login-
login--`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}