import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9](-?[a-z0-9])*$";
final String string = "login\n"
+ "lo-gin\n"
+ "Log23gin\n"
+ "log2-3gin\n"
+ "L--login\n"
+ "L--lo--gin\n"
+ "L---login\n"
+ "---login\n"
+ "login-\n"
+ "login--";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}